Houston Texas 5/28 Area Power Outage

Incident Report for TPx

Resolved

We are seeing all of our customers restored.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 31, 2024 - 00:04 PDT

Investigating

We are currently experiencing a Major service disruption in the Houston, Texas surrounding area due to power outages.

Users may be experiencing service disruption due to loss of power. Our Operations teams are engaged in notifying customers and reviewing news feeds for when power will be restored.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 28, 2024 - 13:48 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).