Multiple Markets
Incident Report for TPx
Resolved
We have restored our application and testing has confirmed issues have been resolved.
Posted May 18, 2023 - 11:14 PDT
Identified
TPx is currently troubleshooting technical difficulties that arose with one of our applications. We continue to handle customer queries and manage our operations. Our IT organization is working with the appropriate resources towards resolution.

Please contact our support organization should you have an immediate need via the following options:
• Online: Create a new case or Request an update at https://www.tpx.com/support/
• Phone: 877-487-8722 (Premier Accounts: 888-611-8722)
• Chat: https://www.tpx.com/contact-us/contact-support/
Posted May 12, 2023 - 11:14 PDT
This incident affected: Network Infrastructure (System Applications).