Advisory - Hurricane Milton
Incident Report for TPx
Resolved
We are seeing some circuits impacted by loss of power and other damages due to Hurricane Milton begin to be restored. We hope our customers businesses and family made it through this major weather event.

We want to emphasize that TPx will make every effort to assist our customers with the restoral of our services.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Oct 10, 2024 - 14:19 PDT
Monitoring
Various Weather Bureaus are reporting Hurricane Milton is expected to reach Florida landfall sometime Wednesday night or early morning Thursday. Florida is on alert for potential damaging winds, flash flooding, and storm surge.

The TPx network is prepared for such events, and we want to ensure our customers that we will make every effort to maintain services throughout this weather event.

With the possibility of service impacts we would like to assure you that our dedication continues to be focused on supporting our customers. Our Support and Engineering Teams are closely monitoring the situation and will continue to do so throughout the duration of the storm.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Oct 09, 2024 - 09:03 PDT