Multiple Markets
Incident Report for TPx
Resolved
TPx has completed restoration of the phone system and inbound calling capabilities have been restored.
Posted Jul 21, 2021 - 13:55 PDT
Update
TPx has made routing changes to establish customer inbound calling capabilities. Customers may experience longer hold times. TPx continues restoration on the phone system and will provide a status update soon. Customers can continue to open a case or check the status of a case please go to TPX.com/Support or use your Dash account to open a service request.
Posted Jul 21, 2021 - 12:04 PDT
Identified
The teams have identified a temporary impairment of our inbound phone system, we apologize for this inconvenience. To open a case or check the status of a case please go to TPX.com/Support or use your Dash account to open a service request. Resources have been engaged and are investigating the issue.
Posted Jul 21, 2021 - 11:39 PDT