CenterPoint Energy has announced that 99% of customers impacted by the power outages from the severe storms have power restored. Any remaining outages are predominantly isolated instances in certain locations where substantial damage still exists.
We have 6 customers, of the 107 tracked cases, still showing as down. Our Support teams are working directly with those customers to assist with restoring their services.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 24, 2024 - 10:43 PDT
Update
We are still monitoring news for updates for power restoral in the Houston, Texas area. CenterPoint Energy continues repairs on its infrastructure. They reported they are on track to substantially complete storm-related outages this evening.
We are seeing many of our customer's services have been restored. 89% of TPx customers impacted by the power interruption are restored.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 22, 2024 - 15:03 PDT
Update
We are still monitoring news for updates for power restoral in the Houston, Texas area. CenterPoint Energy continues repairs on its infrastructure. They reported that 85% of the power customers impacted by the recent storm have been restored.
We are seeing many of our customer's services have been restored. 82% of TPx customers impacted by the power interruption are restored.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 21, 2024 - 08:06 PDT
Update
We are still monitoring news for updates for power restoral in the Houston, Texas area. CenterPoint Energy continues repairs on its infrastructure.
We are seeing many of our customer's services have been restored. We are at 75% of reported calls in the area have been restored.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 20, 2024 - 07:23 PDT
Monitoring
We are still monitoring news for updates for power restoral in the Houston, Texas area.
The local power company, CenterPoint Energy, has not put out a statement for possible restoral times. Today they are evaluating the damage, which is described as extensive.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 17, 2024 - 10:16 PDT
Identified
The TPx NOC continues to monitor internet news for updates for power restoral for this event.
The local power company has distributed the below statement:
"There has been damage to several of our facilities in the Houston-area service territory. As the line of severe weather has made its way through our region, it is now safe for our crews to begin assessing damage but can confirm we’ve experienced significant damage to our system. Restoration efforts will begin tonight but will ramp up in daylight hours as the damage becomes more visible. We are committed to restoring power to our customers as safely and as quickly as possible."
They stated over 1,000,000 customers have been impacted by the severe storms that have blown through the region.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 16, 2024 - 20:38 PDT
Investigating
We are experiencing a Major service disruption impacting Connectivity Services in the Houston, Texas area.
Users may be experiencing service disruption/degradation impacting voice, data, and internet connectivity due to citywide loss of power. We are monitoring power grid outage maps for updates on power restoral timeframes.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 16, 2024 - 18:09 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).