We have confirmed that the Microsoft issues have been resolved.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jan 23, 2026 - 13:56 PST
Monitoring
Microsoft's rebalance of traffic to achieve recovery appears to be working. Some email delays may still be present due to customer email systems processing delivery of backlog messages. They are also recursively monitoring the extent of the affected environment to identify whether additional actions may be required.
TPx will continue to monitor for any further issues through the next 24 hours to verify that our customer issues have been corrected.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jan 22, 2026 - 21:16 PST
Update
Microsoft has implemented a traffic balancing solution within a limited portion of their infrastructure and testing indicates some success. They are applying this solution incrementally across all affected infrastructure to ensure the environment remains balanced as recovery continues.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jan 22, 2026 - 15:22 PST
Identified
Microsoft has announced that it is experiencing a potential issue affecting Microsoft 365 services. They have identified a portion of dependent service infrastructure in the North America region that is not processing traffic as expected. This is impacting their load-balancing processes and general service availability. They are working to restore the infrastructure to a healthy state and rebalance the service traffic to achieve recovery.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jan 22, 2026 - 13:32 PST
This incident affected: Microsoft 365 (Exchange Online).