Microsoft O365 Email
Incident Report for TPx
Resolved
This issue has been resolved, closing notification.
Posted Apr 22, 2021 - 10:43 PDT
Update
We are continuing to monitor for any further issues.
Posted Apr 22, 2021 - 10:42 PDT
Monitoring
Microsoft has recovered the underlying database components and confirmed that new emails are processing as expected without delays. However, during the incident, a queue of email messages built up. The service is automatically retrying these emails and we expect recovery within the next hour. We're monitoring the service to confirm these email queues are processing correctly. Organizations will see recovery at different times depending on their volume of queued emails.
Posted Apr 22, 2021 - 09:21 PDT
Identified
Microsoft preliminary investigation has determined impact is being caused by a load balancing configuration issue. This occurs when a call to validate inbound mail is received. This call is being duplicated, creating a spike in utilization. We're working to restore the underlying database infrastructure to remediate impact.

The impact is specific to organizations hosted from infrastructure located in North America. However, if a user not hosted on the affected infrastructure attempted to send an email to a user within an impacted organization, they may be unable to send the email.
Posted Apr 22, 2021 - 08:51 PDT
Investigating
User Impact: Users may be unable to send or receive email messages within the Exchange Online service.
Microsoft is reviewing service monitoring telemetry to isolate the source of the issue and establish a fix.
The impact is specific to users who are hosted out of the affected infrastructure in North America.
Posted Apr 22, 2021 - 08:40 PDT