SCE has finished repairs to their damaged transformer and we are seeing our customers services restored.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Dec 26, 2024 - 11:52 PST
Monitoring
SCE has made great progress restoring power to most of the customers affected by its power outage. Only 8 out of 94 customer reports appear to be down still.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Dec 25, 2024 - 08:52 PST
Update
SCE is reporting that a transformer failure at one of its substations caused a widespread power outage. SCE crews were able to re-route power to get some impacted customers back online, but no restoration time was given for the remaining SCE clients.
The SCE crew reroutes have restored service for some of our customers but others remain down. We will continue to monitor the SCE website for updates.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Dec 24, 2024 - 16:50 PST
Identified
At approximately 1:30 p.m. PST, Southern California Edison, SCE, experienced an area-wide power outage that affected 27,000 SCE customers in the Paramount, Downey, Santa Fe Springs, and Whittier, CA, areas.
SCE has been dispatched to investigate the cause of the outage. The core TPx network has not been affected but local power to businesses may be down at this time, We will provide additional information as it becomes available.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Dec 24, 2024 - 15:35 PST
This incident affected: Network Infrastructure (Ethernet Carrier Connections).