The recommended Security Updates have been applied to our customers.
Posted Mar 20, 2024 - 07:53 PDT
Update
We are continuing to monitor for any further issues.
Posted Feb 09, 2024 - 12:19 PST
Monitoring
To Our Valued Customers,
At TPx, ensuring the security and reliability of our services is paramount. In our continuous effort to safeguard our systems, we want to highlight our recent proactive steps taken in response to identified security concerns.
Security Enhancements Underway Recent security assessments have led us to initiate enhancements to affected customers. These improvements are designed to fortify our network against identified vulnerabilities, ensuring the ongoing protection of the services we provide.
Impact and Measures: • Service Continuity: We have carefully planned these upgrades to ensure that any impact on our services is minimal. Customers may notice brief periods where services are less responsive than usual. We are committed to providing advance notice for any planned service adjustments. • Strengthened Security: The completion of these upgrades will significantly enhance the security framework of our systems. Our team is implementing robust security measures to mitigate potential threats effectively.
Commitment to Excellence: Your trust in our services is of the utmost importance to us. We are dedicated to resolving these security concerns swiftly and efficiently, ensuring that our systems meet the highest standards of security and reliability.
Contact Us: Should you have any inquiries or require further information, please do not hesitate to reach out to our Security Department. Our support team is available to assist you with any questions you may have. https://www.tpx.com/contact-us/contact-support/
We appreciate your understanding and continued trust in TPx. Our team is working diligently to enhance our systems and keep our services secure and reliable.