Frontier has completed the swap of the last card and services remain stable. Closing this event.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Aug 25, 2025 - 12:11 PDT
Monitoring
TPx customers may have experienced a service interruption due to a hardware issue on the Frontier Network. We are seeing all proactive alerts for customers impacted as restored. Frontier states they are still working with their vendor to restore another card to ensure redundancy. The TPx NOC is monitoring services and will resolve this event once Frontier is hands-off. Frontier has not provided an ETR for when they will be done with full restoration.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Aug 24, 2025 - 22:59 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).