Houston Texas Power Event - 7/8/24
Incident Report for TPx
Resolved
We have confirmed that all TPx customers except 6 have been restored. CenterPointe Energy has restored 2.2 million customers that were without power due to Hurricane Beryl.

We hope our customers are safe and moving forward after this major weather event.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Jul 16, 2024 - 21:41 PDT
Update
CenterPointe Energy continues to work to restore power. Currently, the number of affected users without power is approximately 200,000 with over 2 million customers with power restored.

We are seeing 75% of our original proactive alert customer cases have been restored. We will continue to monitor power restoral progress.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Jul 15, 2024 - 07:55 PDT
Update
CenterPointe Energy continues to work to restore power. Currently, the number of affected users is approximately 800,000 customers, a reduction from 1.2 million reported yesterday.

We are seeing 74% of our original proactive alert customer cases have been restored. We will continue to monitor power restoral progress.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Jul 12, 2024 - 15:01 PDT
Update
CenterPointe Energy continues to work to restore power. Currently, the number of affected users is approximately 1.3 million, a reduction from 1.7 million reported yesterday. Due to the extensive damage inflicted on the power infrastructure by the intense storms and hurricane-strength winds, some regions may continue to experience power fluctuations for up to a week.

TPx will continue to monitor and provide updates as they become available.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Jul 10, 2024 - 08:25 PDT
Update
CenterPoint Energy has restored over 600,000 customers' power, however, they still have over one million customers without power. We are seeing a few more customer circuits restored but still have over 75% that are still down.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Jul 09, 2024 - 21:49 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 09, 2024 - 07:56 PDT
Update
CenterPointe Energy is progressing in restoring power as they recover from Hurricane Beryl. Approximately 19% of the 275 customers initially reported as down have services restored.

We will continue to follow progress on power restoral and provide updates as they occur.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Jul 09, 2024 - 07:39 PDT
Identified
We are experiencing a Critical service disruption impacting multiple services in Houston, TX, and the surrounding areas.

Users may be experiencing service disruption due to an area-wide power outage in and around Houston Texas.

The power outage is attributed to rain and wind damage caused by Hurricane Beryl which made landfall earlier today 7/8/2024.

We will follow the progress for power restoral from CenterPoint's Power Outage map and other independent updates on the internet.

We will provide updates when available.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Jul 08, 2024 - 10:01 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).