Texas - Spectrum Outage

Incident Report for TPx

Resolved

Spectrum has completed the repair of the fiber optic cable and services have been restored.

If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jun 11, 2026 - 15:45 PDT

Investigating

Our proactive alerting systems have identified multiple customer services impacted on the Spectrum network in various locations in Texas. We have contacted Spectrum, which is aware of the event and is investigating a suspected fiber cut. They have engaged their 3rd party vendor to locate and repair the suspected fiber damage.

If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jun 11, 2026 - 12:09 PDT
This incident affected: Networking Services (TPx Internet Access).