California Weather Advisory
Incident Report for TPx
Resolved
The west coast storms have subsided and there is a forecast of sunshine for the next 10 days. Business has restored to normal.
Posted Apr 04, 2023 - 12:34 PDT
Update
Northern California is expecting another 1 to 2 inches of rain due to a strengthening winter storm system over the Pacific. The system is expected to bring damaging winds, rain, and heavy mountain snow beginning Tonight

These events have the potential to impact services across California and could affect response times.

The TPx network is prepared for such events, and we want to assure our customers that we will make every effort to maintain services throughout these weather events.

If you feel your service is being impacted and to avoid any potential delays due to high call volume, please open a case with our technical support teams at www.tpx.com/support/
Posted Mar 27, 2023 - 17:27 PDT
Monitoring
Weather forecasters are predicting several inches of rain due to yet another storm system hitting California. This new system is expected to cause heavy rain over the next 3 to 5 days.

These events have the potential to impact services across California and could affect response times.

The TPx network is prepared for such events, and we want to assure our customers that we will make every effort to maintain services throughout these weather events.

If you feel your service is being impacted and to avoid any potential delays due to high call volume, please open a case with our technical support teams at www.tpx.com/support/
Posted Mar 10, 2023 - 09:21 PST