We see that services have been stable with no further interruptions. Resolving this event.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Feb 18, 2026 - 08:37 PST
Monitoring
One of our redundant links has restored and the Las Vegas Market is now back up. We are monitoring the service and awaiting a root cause from our Provider.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Feb 18, 2026 - 05:32 PST
Investigating
We are currently experiencing a major outage in the Las Vegas Area. We are escalating with our Providers for immediate investigation.
If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Feb 18, 2026 - 04:47 PST
This incident affected: Support Infrastructure (TPx Customer Portal).