Palm Springs Area

Incident Report for TPx

Resolved

We have confirmed with customers that services are back to normal.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 27, 2025 - 12:42 PDT

Monitoring

We have made a configuration change that appears to have corrected the congestion we were seeing on our network. Our Support teams are reaching out to affected customers for confirmation their services are no longer impacted.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 27, 2025 - 12:09 PDT

Investigating

Our Support team is seeing an influx of customer calls reporting slow internet speeds. We are gathering the data to correlate any potential cause for the service degradation.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 27, 2025 - 10:47 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).