Frontier Outage - Los Angeles Area

Incident Report for TPx

Resolved

Frontier has completed repairs to the damaged fiber-optic cable, and services have been restored as of 7:11 pm Pacific Time.

If you believe your service is still impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Apr 28, 2026 - 21:03 PDT

Identified

TPx customers in the greater Los Angeles area may be experiencing intermittent service interruptions. Our investigation has correlated these issues with the Frontier Network.

Frontier has identified a fiber cut in their network and has a fiber construction team at the location.

If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Apr 28, 2026 - 17:32 PDT
This incident affected: Networking Services (TPx Internet Access).