If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 31, 2024 - 12:43 PDT
Monitoring
We continue to monitor the power outage in the Dallas Texas area. The local power company is still reporting over 200,000 customers are without power due to the recent storms. 78% of our impacted 142 customers have been restored as of 5/29.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 29, 2024 - 17:45 PDT
Investigating
We are experiencing a Critical service disruption impacting voice and internet services in the surrounding Dallas, Texas area.
Users may be experiencing service disruption impacting their services. Our Operations teams are engaged with our Provider technical support teams who are currently investigating issues related to what appears to be an area-wide power outage.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 28, 2024 - 06:43 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).