Microsoft Exchange Online Outage

Incident Report for TPx

Resolved

There have been no further customer impact to this event
Posted Mar 03, 2025 - 13:06 PST

Monitoring

The issue appears to be cleared as of 1:45 PM PST. We're now monitoring for service restoration.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 01, 2025 - 13:52 PST

Investigating

We are seeing reports of Microsoft Exchange Online being down. This event is affecting more than just TPx customers. Seems as though it is more widespread. We are engaging our engineering team to assist with investigation.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 01, 2025 - 13:17 PST
This incident affected: Microsoft 365 (Exchange Online).