Los Angeles Area Slow Speed

Incident Report for TPx

Resolved

Customers have reported that services are back to normal.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Apr 08, 2025 - 13:36 PDT

Investigating

One of our Internet Connectivity Providers has experienced a service interruption on their network. TPx has failed over to our redundant Internet Connectivity Provider. We are testing customers that had report slow speed issues to verify the failover has corrected the issue.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Apr 08, 2025 - 10:27 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).