Our Provider has completed all fiber optic cable repairs and our customer services have been stable over the weekend.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 05, 2025 - 06:57 PDT
Monitoring
Our provider has successfully rerouted services over spare fiber optic cable pairs, temporarily restoring services for our customers.
However, they have advised that intermittent connection drops may still occur while ongoing fiber repairs continue.
A new Estimated Time of Restoration (ETR) has been provided: May 3, 2025, at 10:00 AM.
Posted May 02, 2025 - 12:47 PDT
Investigating
The TPx proactive monitoring system reports a service interruption on one of our service providers in Houston, Texas area. We have engaged the provider for more details.
If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted May 02, 2025 - 09:53 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).