Texas Power Outage

Incident Report for TPx

Resolved

We see that our customers' services are restored.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 05, 2025 - 06:56 PST

Update

We are seeing some of our customers' services restored. TPx will continue to monitor the progress of the power restoration throughout the night.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 04, 2025 - 21:02 PST

Monitoring

The Dallas / Fort Worth area was hit by severe thunderstorms this morning that have caused numerous customers to be without power. We are monitoring social media and Texas power outage maps for any updates on when power will be restored in the area.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Mar 04, 2025 - 08:49 PST
This incident affected: Network Infrastructure (Ethernet Carrier Connections).