Informational Update
Incident Report for TPx
Resolved
Service restoration has been verified, TPx has resolved this incident.
Posted Mar 30, 2021 - 18:47 PDT
Monitoring
We are currently experiencing intermittent connectivity issues with our support number (877) 487-8722. If you wish to log a case or track the status of a case please visit www.tpx.com/support.
Posted Mar 30, 2021 - 15:07 PDT