Advisory - Hurricane Helene
Incident Report for TPx
Resolved
Customer services that Hurricane Helene damaged are slowly recovering. The event did not impact our core TPx network. Our Atlanta Hub did not experience any interruption of backbone network connectivity.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Sep 30, 2024 - 09:08 PDT
Update
We continue to monitor the path of Hurricane Helene. This is a major hurricane possibly reaching Category 4 level. Helene's Florida landfall is expected late Thursday night into Friday early morning.

The TPx network is prepared for such events, and we want to ensure our customers that we will make every effort to maintain services throughout this weather event.

With the possibility of service impacts, we assure you that our dedication continues to focus on supporting our customers. Our Support and Engineering Teams are monitoring the situation and will continue to do so throughout the storm.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Sep 26, 2024 - 15:06 PDT
Monitoring
Various Weather Bureaus are reporting Hurricane Helene is expected to reach Florida landfall sometime Thursday night. Florida is on alert for potential damaging winds, flash flooding, and storm surge.

The TPx network is prepared for such events, and we want to ensure our customers that we will make every effort to maintain services throughout this weather event.

With the possibility of service impacts we would like to assure you that our dedication continues to be focused on supporting our customers. Our Support and Engineering Teams are closely monitoring the situation and will continue to do so throughout the duration of the storm.

If you feel your service is being impacted, please open a case with our technical support teams at www.tpx.com/support/.
Posted Sep 25, 2024 - 14:25 PDT