Boston
Incident Report for TPx
Resolved
The Massachusetts 911 system has been restored.
Posted Jun 18, 2024 - 12:56 PDT
Identified
TPx is aware that inbound calls to 911 services in Massachusetts are currently down. The issue concerns 911 services not being delivered to the 911 centers that TPx does not control.

If you are experiencing an emergency it is recommended you contact your local authorities via their local contact number for assistance.
Posted Jun 18, 2024 - 11:45 PDT
This incident affected: Communications (PRI / SuperTrunk).