Riverside Area Fiber Outage

Incident Report for TPx

Resolved

Fiber Repairs have been completed as of 1:45 am. All customer services impacted have been confirmed backup.

If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jul 13, 2025 - 10:03 PDT

Identified

TPx customers may be experiencing service disruptions due to a Major Outage in the Riverside county area.

We have correlated the proactive alerts to an issue within the Frontier Network. We are actively escalating with Frontier who have dispatched a Fiber team to the suspected area to isolate the problem.

If you believe your service is impacted, please open a support case with our technical teams at www.tpx.com/support.
Posted Jul 12, 2025 - 10:57 PDT
This incident affected: Network Infrastructure (Ethernet Carrier Connections).