Microsoft Azure Service Issues

Incident Report for TPx

Resolved

Microsoft Azure determined the service interruption was due to a maintenance activity that caused traffic issues across their Wide-Area Network connections in one of their West US region data centers. They initiated a rollback of the maintenance change request, monitored recovering telemetry and services to confirm services recovered.

If you believe your service is being impacted, please get in touch with our support team at www.tpx.com/support
Posted Jul 24, 2026 - 07:45 PDT

Identified

We are investigating intermittent service interruptions of services connecting to Microsoft Azure resources. Microsoft Azure has stated that they are investigating a networking issue affecting connectivity to Azure services in the West US region. Customers may experience intermittent connectivity failures, increased latency, or difficulty accessing Azure services.

We will continue to monitor and provide updates as we get them from Microsoft.

If you believe your service is being impacted, please get in touch with our support team at www.tpx.com/support
Posted Jul 23, 2026 - 11:49 PDT
This incident affected: Collaboration Services (Microsoft 365).